Frontier y Oculus no logran adaptar Elite Dangerous al SDK 0.7

8 OCT 2015  13:43

Juanlo

17

Frontier y Oculus no logran adaptar Elite Dangerous al SDK 0.7

Elite Dangerous paralizó sus actualizaciones al último SDK de Oculus hace meses, quedando el juego estancado en el 0.5, y parece que va a seguir ahí durante un tiempo.

Ayer mismo, Zac Antonaci, Community Manager de Frontier Developments, informó en el foro de la situación de Elite: Dangerous respecto al SDK 0.7, y las noticias no son nada buenas.

 

Hemos dado nuestro apoyo a Oculus tanto como hemos podido, pero Elite: Dangerous no es compatible con el SDK 0.7 de Oculus, y la versión 1.4 [de Elite Dangerous] no lo cambia. Esperamos hacerlo funcionar en una futura versión del software para poder seguir trabajando con ellos en esto. Elite: Dangerous 1.4 sigue funcionando con el SDK 0.5 y 0.6 de Oculus, pero seguimos pidiendo a los jugadores que no actualicen su SDK más allá del 0.7 si quieren seguir jugando a Elite: Dangerous. Nuestro soporte para RV sigue mejorando y ahora también damos soporte a SteamVR y al HTC Vive.

 

Posteriormente aclara todavía más la situación, ante las insinuaciones de algunos miembros del foro de que podría deberse a algún tipo de acuerdo con Valve y HTC, algo que está muy lejos de ser verdad, según Zac.

 

Entiendo que haya cierta preocupación, pero os puedo asegurar que los problemas que tenemos con Oculus son estrictamente técnicos. Tanto el equipo de Oculus como el de desarrollo del juego han trabajado realmente duro para encontrar una solución, pero lamentablemente no ha sido posible. Es algo que a nuestro equipo le gustaría poder resolver en un futuro.

 

Elite: Dangerous

 

Así pues, el párrafo anterior deja muy claro que ya han realizado todos los esfuerzos posibles con el SDK 0.7 y no van a ir más allá, por tanto la deseada solución tendría que venir de la mano de un nuevo SDK. Pero... ¿cuál es el impedimento técnico exacto al que alude Zac? Por el momento no han dado más información al respecto, pero viendo la historia del juego, diríamos que se trata de algo relacionado con el modo Directo, algo que Frontier nunca ha conseguido hacer funcionar. Incluso cuando llegó la esperada actualización al SDK 0.4.4, Frontier ya comunicó que había que jugar al juego en modo extendido, y que estaban trabajando con Oculus para solucionar los problemas con el modo Directo. Todo esto ocurría en diciembre del año pasado, eso supone casi un año sin que hayan logrado que el juego funcione en modo Directo, con ninguna de las versiones del SDK de Oculus. Es posible que el motor Cobra creado por Frontier tenga alguna característica que impida utilizar el modo Directo, y lo que no sabemos es si Oculus puede hacer algo desde su SDK para facilitarles esa integración, o si es Frontier quien tendría que realizar cambios importantes en su motor para ello. Otros juegos que utilizan motores propios, como Project CARS y DCS, han logrado actualizar al SDK 0.7, y resulta extraño que con Elite Dangerous no sean capaces de hacer lo mismo.

 

Por fortuna, el caso no está perdido, y es que Frontier Developments se reafirma en su intención de que el juego funcione perfectamente cuando se lance la versión comercial del Rift, pero no parece que dicha solución vaya a llegar en las próximas semanas ni con el SDK actual.