Oculus anuncia el SDK 0.7 con integración en drivers de AMD y nVidia

El 20 de agosto llega un importante cambio en el SDK de Oculus con el lanzamiento de la versión 0.7, que incluye un nuevo modo "directo al driver" desarrollado en colaboración con AMD y nVidia.

7 AGO 2015  16:39

Juanlo

34 comentarios

Oculus anuncia el SDK 0.7 con integración en drivers de AMD y nVidia

Esta nuevo modo directo ofrecerá importantes mejoras de rendimiento, latencia y compatibilidad, pero también tendrá consecuencias muy negativas para las aplicaciones desarrolladas con anterioridad, y es que no podremos ejecutar ninguna aplicación compilada con los SDKs 0.4 ni 0.5, lo que incluye a todo el contenido generado con la versión 4 de Unity. Así pues, las aplicaciones que no se hayan actualizado al menos al SDK 0.6 dejarán de funcionar en nuestros DK2 cuando instalemos el runtime 0.7.

 

SDK 0.7 de Oculus

 

Adiós al modo extendido

 

El modo "directo al driver" sustituye por completo al modo extendido, y necesitaremos nuevos drivers por parte de nVidia y AMD que, suponemos, llegarán a la vez que este nuevo SDK previsto para el 20 de agosto. Nos parece curioso que no se haya mencionado absolutamente nada sobre la esperada compatibilidad con Windows 10.

 

El camino al SDK 1.0

 

Oculus tiene previsto lanzar la versión 1.0 del SDK en noviembre de este año, y todas los futuros SDKs que lleguen después (1.1, 1.2, 2.0 en su momento) podrán ejecutar las aplicaciones generadas con la versión 1.0, que pondrá punto y final a la necesidad de actualizar al último SDK. Sin embargo, las distintas revisiones del SDK que se lancen entre la 0.7 y la 1.0 solo serán compatibles con la versión anterior, lo que significa que cuando llegue la 0.8 podremos ejecutar el software creado para la 0.7, pero no para la 0.6. Esto puede suponer un trabajo muy importante para los desarrolladores que utilicen motores propios, y menos complicaciones para los que construyan sus aplicaciones con Unity 5 o Unreal Engine 4. Según Oculus, se trata de un mal necesario para mejorar y evolucionar la arquitectura y la API.

Comentarios (34)

Enlace al foro
  • Pablo:Desbancar el soporte para unity 4.0 me parece una pu**** del copón y una locura. Hacer un port de un proyecto a más de medio camino es un suicidio. Además de que la iluminación del 5.0 es un churro de alucine con unos tiempos de baking de locura. -1


    Eso mismo estaba pensando. Portar todo mi proyecto ahora es una locura yo me quedo como estoy y mas adelante cuando salga la compatibilidad de w10 me hare un dual boot particionado y segun lo que quiera hacer con el.dk2 elegire el que convenga.

    Aunque sea un DK no deberian dejar asi de tirados a todos sus usuarios que estan desarrollando proyectos que luego daran contenido a su producto cuando salga el cv1.

    Mucho dinero para que otros hagan software y para los que lo hacemos gratis nos joden vivos.
    0 0
  • Como comenté hace aproximadamente un año por estas fechas, y que algunos me dieron bastante la lata con ello, existen en Oculus dos ramas del desarrollo del SDK, una la que es la 0.6 y ahora la 0.7, que está orientada a los devs que tienen el DK2 sólo (los campesinos del development de RV), y la otra es la 1.0, orientada a estudios escogidos que tienen ya versiones dev del CV1 (los estudios VIP de la RV, como CCP y compañía).

    Algunas features del 1.0, cuando las ven estables y útiles para los devs campesinos, las van metiendo en el SDK 0.5/0.6/0.7. Es arriesgado porque ahí tienen a 100.000 compradores de DK2, muchos de ellos devs, que como algo les casque se van a poner de uñas, así que en Oculus no son tontos y sacan features que les den pocos problemas de soporte, prefieren tener todos los problemas de soporte del mundo, lógicamene, sólo con 100 estudios escogidos que con 5000 devs indie con mala leche.

    Todo esto lo digo con aparente tono de queja, pero no es así. Comprendo perfectamente la situación de Oculus, en mi profesión trabajo en el desarrollo de SDKs y sé de buena mano la locura que es sacar SDKs de desarrollo a un número tan elevado de developers.

    La conclusión de todo esto es que los que tenemos un DK2 para desarrollar vamos a tener realmente que esperar a la salida comercial del CV1 para poder finalizar nuestros productos y depurarlos bien antes de sacarlos, y esto sitúa a miles y miles de devs en una parrilla de lanzamiento posterior a la salida del CV1, lo cual dejará muy poco material para los consumidores en los momentos iniciales de la release. Y a Valve HTC les va a pasar lo mismo.

    Lo que empiezo a repetir como un papagayo últimamente. Paciencia, amigos, mucha paciencia...
    0 0
  • blade75:pues yo no he conseguido hacerlo funcionar con la version 0.6.0.0  :sad:


    Acabo de probar Alien Isolation con el SDK 0.6.1 en modo extendido, parando el servicio de Oculus, y funciona perfectamente.
    0 0
  • Muy interesante. Gracias por explicarlo con tanto detalle.

    Saludos.
    0 0