Las demos creadas con la versión 0.2 del SDK de Oculus no funcionarán con el DK2

23 JUN 2014  8:42

Juanlo

37

Las demos creadas con la versión 0.2 del SDK de Oculus no funcionarán con el DK2

El Community Manager de Oculus VR, conocido en los foros como Cybereality, ha confirmado en un hilo del foro oficial algo que ya intuíamos hace algún tiempo: las demos y juegos que no hayan sido recompilados usando la última versión del SDK no funcionarán correctamente con el DK2, de hecho la versión 0.3.2 ni siquiera implementa todavía posicionamiento absoluto.

Según hemos podido leer en un hilo del foro oficial de Oculus VR, en el que un usuario preguntaba si las demos y juegos existentes funcionarían en el DK2, Cybereality ha respondido lo siguiente:

"Hay un par de demos recientes que funcionarán, sin embargo la mayoría no lo hará. Estamos buscando crear un sistema en Oculus Share para etiquetar demos como compatibles con DK2. En este momento recomendamos a los desarrolladores empezar a familiarizarse con la última versión del SDK (0.3.2). Si bien no está completamente terminado aún, el API debería estar muy cerca del SDK definitivo que sacaremos cerca del lanzamiento del DK2. Los juegos creados con el SDK 0.3.x funcionarán con el DK2 (hasta cierto punto) pero habrá que esperar al próximo SDK para desbloquear todas las características."

Otro forero pregunta si es muy complicado recompilar una demo con el nuevo SDK, y Cybereality responde así:

"Para muchos juegos de Unity, en realidad es sólo un proceso de arrastrar y soltar (a menos que hayas modificado el OVRPlayerController, cosa que la mayoría de personas no habrán hecho). Para otros motores requerirá más trabajo, pero no es tan difícil. Tal vez a un desarrollador que trabaje en él le llevaría desde unos días hasta una semana."

Así que basándonos en esto podemos deducir que, al menos, las demos y juegos que se hayan lanzado o actualizado con posterioridad al lanzamiento de la versión 0.3.2 del SDK de Oculus deberían funcionar correctamente con el DK2 (sin posicionamiento absoluto) si sus autores usaron esa versión para compilarlas, y tenemos la confirmación de que las más antiguas no funcionarán salvo que sus creadores se tomen el trabajo de recompilarlas. Era algo que ya sospechábamos que pasaría, pero las palabras de Cybereality lo confirman. Por tanto habrá muchas viejas demos que quizá nunca lleguemos a poder disfrutar en el DK2, pero seguramente irán saliendo otras muchas para que no nos falte material para dar de comer a nuestros Rifts. Y con respecto a las características que aún faltan por implementar en el SDK, como el posicionamiento absoluto, tendremos la misma historia: habrá que volver a recompilar las demos y juegos en cuanto lancen un SDK que habilite esta función (para lo cual no debe faltar mucho), aunque esto si que es algo que ya sabíamos con certeza.