Tema: Guía para inútiles sobre los SDK

Mensajes

  • ChristianDan

    22 Mar 2014 17:26

    Mensajes: 422

    Ubicación: Madrid

    ChristianDan » 13 AGO 2014  10:45
    Hola a todos!
    Antes de nada , comentaros que ya tengo mi Dk2 esperándome en casa! Y digo esperándome porque ahora me encuentro a 600 km de mi hogar disfrutando de la playa y las vacaciones
    Así que, tendré que esperar unos cuantos días aún antes de probar mi flamante Rift.

    El caso es que no hago más que leer sobre los SDK y me estoy haciendo bastante lío. Y estaría genial si alguien pudiera aclarar a un inútil como yo, en que consisten los SDK

    Por ejemplo , cuantas versiones de SDK pueden correr al mismo tiempo....
    Si las Dk2 pueden correr demos con versiones anteriores de SDK

    Estas serán mis primeras Rift y tengo aún un poco de lío, pero a mi favor tengo que decir que llevo muchísimos años trasteando con la informática y me adapto bien a las nuevas tecnologías

    Gracias !!
    --------------------------------------
    http://www.christiandan.com
    http://www.arteyanimacion.es
    0 0
  • JotaJake

    9 Sep 2013 00:59

    Mensajes: 171

    JotaJake » 13 AGO 2014  10:55
    Así a grosso modo, el SDK es lo que usan los desarrolladores para hacer sus juegos compatibles con el Oculus. Si no eres desarrollador no lo necesitas para nada.
    0 0
  • knack

    28 Jul 2014 21:01

    Mensajes: 1762

    knack » 13 AGO 2014  10:57
    El SDK son las librerias de desarrollo. Vamos no las necesitas para nada. Lo necesitan los desarrolladores para que su aplicacion funcione con la rift.

    Normalmente deberia haber compatibilidad pero hubo un problema de incompatibilidad entre versiones cuando paso de la 0.3 a la 0.4, se sigue pudiendo utilizar las aplicaciones compiladas para 0.3 pero hay que cargarse el servicio oculus que instala la 0.4 por que no se llevan bien.

    Tu solo tienes que bajarte el runtime y preocuparte de mantenerlo actualizado, y cuando te bajas una demo si no te va el tracking posiblemente es por que este compilado con el 0.3 y tienes que utilizar el truco.
    0 0
  • Juanlo

    Moderador

    11 May 2013 12:53

    Mensajes: 7904

    Ubicación: Murcia (España)

    Juanlo » 13 AGO 2014  11:06
    Te aconsejo que leas el primer post del hilo de primeros pasos con el DK2:

    viewtopic.php?f=3&t=3505
    0 0
  • ChristianDan

    22 Mar 2014 17:26

    Mensajes: 422

    Ubicación: Madrid

    ChristianDan » 13 AGO 2014  11:15
    ah.. quizá estaba confundiendo los SDK con el runtime.

    Entonces básicamente, se trata de tener siempre la ultima versión de runtime no?

    Cuando yo me baje el último runtime, automáticamente se me instalará el 0.4 verdad? por lo que, si yo paro el servicio para ejecutar el 0.3 en realidad no me funcionará nada no?

    Juanlo, estoy en ello, me lo estoy empollando !
    --------------------------------------
    http://www.christiandan.com
    http://www.arteyanimacion.es
    0 0
  • knack

    28 Jul 2014 21:01

    Mensajes: 1762

    knack » 13 AGO 2014  11:27
    Si que te funcionara, el runtime configura ciertas cosas de la rift y actualiza supongo esta información en algun chip de la memoria de la rift y configura la pantalla en el ordenador.

    El sdk accede y lee esos valores y con eso trabaja por eso hay que configurar primero el tema del IPD y luego cargárselo y funcionara igual

    Eso entre comillas por que el 0.3 era independiente del oculus service, pero el 0.4 no, si lo tienes apagado no te funcionan las aplicaciones del 0.4, por eso si quieres otra vez ejecutar aplicaciones 0.4 tendras que arrancarlo. El por que ahora si es dependiente ni idea.
    0 0
  • altair28

    Colaborador

    18 Ago 2013 16:58

    Mensajes: 7838

    Ubicación: En mi mundo virtual

    altair28 » 13 AGO 2014  12:21
    El nuevo SDK accede al headtracking del Rift de forma diferente a como lo hacía el SDK 0.3 por eso en las aplicaciones que se compilaron con ese SDK no funciona el headtracking si está el servicio activo, y por eso hay que pausarlo para que funcione. Eso solo habrá que hacerlo para algunas aplicaciones antiguas para el DK2 que aun siguen compiladas con ese SDK, y cada vez serán menos... Simplemente si pones una demo y el headtracking no funciona, prueba pausando el servicio desde la aplicacion de configuración de Oculus y listos. Activar y desactivar el servicio es ahora muy sencillo y conforme pase el tiempo cada vez habrá que hacerlo menos, hasta que ya no sea necesario volver a hacerlo.

    Y como ya te han dicho, no te preocupes del SDK, no tienes ni que descargartelo (salvo que quieras probar la Oculus World Demo, que es la Tuscany sin mariposas, ni agua ni sonido, y viene incluida dentro de la carpeta del SDK). Un usuario normal solo necesita el runtime, que no es más que un paquete con los drivers del rift y la cámara y las herramientas de configuración y selección de modo. Y cuando haya versiones nuevas, pues se descargan y se instalan, como con los drivers de cualquier otro dispositivo. Ya te mandan un correo de Oculus cada vez que sacan versión nueva, y ya avisamos nosotros por aquí también.
    Mi PC: I5 3570K OC 4,2GHz. Gainward GTX1080 Phoenix GS. 16 Gb RAM
    0 0
  • knack

    28 Jul 2014 21:01

    Mensajes: 1762

    knack » 13 AGO 2014  13:02
    por cierto a mi no me funciona el pause tengo que matarlas igual.

    edito: pues ahora parece que si ayer no.
    0 0