Tema: Problemas con los SDK Runtime de Oculus ¿Qué versión utilizas?

Mensajes

  • Neoskynet

    13 Ago 2014 16:39

    Mensajes: 1947

    Ubicación: Barcelona

    Neoskynet » 23 JUN 2015  12:59
    Hacía días que no utilizaba el DK2, pero aprovechando que ha venido mi hermana y su marido de USA, que ambos trabajan en el sector de los videojuegos, les he preparado varias demostraciones del DK2, y cual ha sido mi sorpresa cuando me he encontrado bastantes problemas con los SDK Runtime de Oculus.

    Yo tenía instalada la versión 0.4.4 y al parecer varios programas, juegos y demos se han actualizado a la versión 0.6.0.0-beta y han dejado de funcionar. Así que me he instalado el SDK Runtime versión 0.6.0.0-beta y me he encontrado con más problemas aún, porque no mantiene la retrocompatibilidad con lo desarrollado anteriormente. Simplemente no funciona nada de lo anterior.

    Al final he optado por instalar la 0.5.0.1 y al menos todo lo anterior está funcionando, pero es un problema porque lo nuevo con la 0.6.0.0-beta no puedo utilizar casi nada.


    Los problemas que he encontrado con la versión 0.6.0.0-beta son:

    - La pantalla del visor se queda en negro y al poner el modo "Extended Desktop to the HMD" simplemente no funciona, mostrando un mensaje en rojo y en el icono sale una marca en rojo. He leido por los foros de Oculus que le pasa a un montón de gente, y que de vez en cuando les funcioaba y al cabo de un rato otra vez les dejada de funcionar. Con las teclas "Windows+P" he conseguido extender el escritorio, pero sigue dando otros problemas. El modo directo si que activa el visor, pero tampoco funciona bien.

    - El Elite Dangerous, que lo acabo de comprar, no funciona en esta versión. He buscado en su foro y allí confirman que no funciona con la 0.6.0.0-beta y que hay que utilizar la 0.5.0.1. Y nadie sabe cuándo lo actualizarán a la 0.6.0.0-beta.

    - Este verano quiero utilizar Unity y UDK, que al parecer utilizan la versión 0.6.0.0-beta, pero si instalo esta versión me encuentro con el problema anterior en modo extendido. Además en los foros hablan de más problemas a la hora de desarrollar con la 0.6.0.0-beta, tanto del propio SDK como del propio Unity y UDK.

    Es decir, que esto es un infierno no sólo para los que quieren probar juegos y demos, sino también para los que quieren desarrollar.

    Esto me confirma la dejadez de Oculus con el visor de RV para PC, porque ahora mismo lo único que tienen los desarrolladores para crear juegos compatibles con el futuro CV1 es el actual DK2. Y si se encuentran con todos estos problemas creo que muchos simplemente desistirán. Y la verdad es que no lo entiendo como Oculus tiene su SDK tan abandonado, con la cantidad de gente buena y dinero fresco que tienen.

    ¿Qué versión de SDK Runtime estáis utilizando?

    Saludos.


    * Nuestro cerebro es un sistema de simulación que virtualiza todo lo que capta del exterior.
    0 0
  • Jose_rv

    31 Mar 2015 19:19

    Mensajes: 1195

    Ubicación: Santa Cruz de Tenerife

    Jose_rv » 23 JUN 2015  13:06
    Comparto tu problema, estoy usando la 0.5 mayoritariamente, pero te podría contar las veces que he instalado la 6 y luego otra vez la 5 y luego la 6 y así llevo desde que salio la 6
    Si querían fragmentacion ya la tienen, espero que aprendan de esto para las CV por que esta resultando una penuria
    0 0
  • enrolao84

    30 Sep 2013 20:23

    Mensajes: 836

    enrolao84 » 23 JUN 2015  13:14
    Yo sigo con la 0.4.4 en prevision de todo lo que ocurre.

    Sabiendo lo que esta pasando simplemente intento que los programas no se actualicen (entrar en steam siempre off-line, ...)

    Principalmente (y casi en solitario) estoy utilizando dolphinvr y como aun siguen con esta version del runtime pues yo tambien.

    Por lo demas veo totalmente logico estos cambios en un producto "Development Kit" e incluso en productos finales, a veces llegar a algo mejor obliga a no ser compatible con lo anterior y mas en un producto en desarrollo donde los desarrolladores iniciales no tienen porque conocer tecnicas que luego con un equipo mejor seran conocidas. Lo logico es que mientras puedan o no sea un problema conserven la compatibilidad con versiones anteriores pero hay momentos que todo a la vez es imposible: mejoras sustanciales y compatibilidad con anteriores.

    A los desarrolladores no deberia darles problemas pues lo logico es que desarrollen con la ultima version y los que han desarrollado en anteriores o lo actualizan o lo dejan, mas o menos como intentar utilizar en un win 64 bits programas de d.o.s. 8 bits.
    0 0
  • Krieghor

    4 Jul 2013 02:36

    Mensajes: 404

    Krieghor » 23 JUN 2015  13:16
    Yo volví a poner el DK1 después de casi un año sin usarlo y fue un horror. La 0.6.0 no funcionaba, no reconocía el Oculus si no era en modo extendido con el Legacy mode pero luego las demos no iban, no lo reconocía Steam ni nada. Fui cambiando de versiones y ninguna iba. Incluso una vez al reiniciar me jodió los drivers de la gráfica y tuve que reinstalarlos.

    En fin que volví a guardar mi DK1 después de estar dos días comiéndome la cabeza. No sé que han hecho.
    0 0
  • Juanlo

    Moderador

    11 May 2013 12:53

    Mensajes: 7904

    Ubicación: Murcia (España)

    Juanlo » 24 JUN 2015  8:20
    Yo uso la 0.6 y no tengo problemas. En el caso de Elite Dangerous, me funciona el truco de apagar el DK2 y volver a encenderlo cuando se pone a parpadear el monitor hasta que entra al juego.
    0 0
  • Fguillotine

    30 Ene 2015 17:20

    Mensajes: 1066

    Ubicación: Vigo

    Fguillotine » 24 JUN 2015  10:05
    Yo llevo unas semanas con la 0.6.0.0. En modo extendido tengo el problema del parpadeo con algunas demos de UE4 y Elite Dangerous, pero apagando y encendiendo el dk2 en esos casos puntuales he conseguido que funcione todo a la perfección. En modo directo esta runtime es la que mejor funciona.

    Saludos
    0 0
  • imho

    7 Mar 2014 06:22

    Mensajes: 1295

    imho » 24 JUN 2015  11:41
    Uso la 0.5.0.1 y es con la que mejor me va en general,como dije en la salida del 0.6,no cambio a esta ultima de momento ni en broma,sobre todo mientras vea que me de la lata ademas en wrappers e.t.c. pero cuando funcione como dios manda,si que lo actualizare.

    0 0
  • Neoskynet

    13 Ago 2014 16:39

    Mensajes: 1947

    Ubicación: Barcelona

    Neoskynet » 24 JUN 2015  22:41
    Volveré a instalar la 0.6.0.0-beta y probaré el truco de apagar y encender el DK2 cuando lo detecta y la pantalla parpadea poniéndose en negro, a ver que tal. No sabía ese truco.

    ¿Con ese truco os funcionan todos los programas con la 0.6.0.0-beta aunque no estén diseñados para ella?
    ¿Ejecutáis todos los programas en modo directo?
    ¿Algún truco más para la 0.6.0.0-beta?

    Saludos.


    * Nuestro cerebro es un sistema de simulación que virtualiza todo lo que capta del exterior.
    0 0
  • Dzbelio

    Moderador

    31 Jul 2014 15:17

    Mensajes: 2083

    Ubicación: Jaén, La Carolina

    Dzbelio » 24 JUN 2015  23:22
    A mi la 6 es la que mejor me está funcionando de todas, 0 fallos
    Real O Virtual
    0 0
  • polybasss

    3 Jun 2014 21:18

    Mensajes: 372

    Ubicación: Allá donde los juegos me lleven..

    polybasss » 25 JUN 2015  0:23
    Pues a mi realizar el " truco " me supuso una pantalla azul dando no se que error, que se arreglo reiniciando el pc pero bueno, no lo he vuelto a hacer por si acaso.

    A mi la 0.6 la que mas problemas me da, estoy con la 5.0.1 y de vez en cuando cambio a la 0.6 para probar cosas concretas, las que vayan en modo directo vamos por que en extendido una m para mi la 0.6, por suerte ya empiezan a llegar cosas en modo directo aunque no terminan de ir finas, a ver con Dx 12.
    i7 4790K-MSI Z97 Gaming 5-MSI Gainward Phoenix Gs 1080 -16GB Ram HTC Vive Cv1
    0 0
  • Neoskynet

    13 Ago 2014 16:39

    Mensajes: 1947

    Ubicación: Barcelona

    Neoskynet » 25 JUN 2015  21:14
    ¿Y alguien ha probado Windows 10 con la 0.4, 0.5 ó 0.6?

    Saludos.
    * Nuestro cerebro es un sistema de simulación que virtualiza todo lo que capta del exterior.
    0 0
  • Rigarmar

    20 Mar 2014 21:22

    Mensajes: 604

    Ubicación: Albacete

    Rigarmar » 25 JUN 2015  22:28
    A mi me ha vuelto loco la 0.6. Estaba haciéndoles un "tour" a unos amigos y más de una demo chula no me funcionaba, por lo que trataba de volver a la 4.0. Que por cierto, en una de esos "ir y venir" de versiones el desisntalador se cargó los controladores gráficos y me tocó volver a bajar y descargar, no veas la gracia.

    Ahora he vuelto a la 0.6 de nuevo, ya que el otro día compré en Steam "Legend of Dungeon", y nome iba ni con la 0.4.3 ni con la 0.4.4, y volví a la más reciente...tampoco.

    Solo me queda probar la 0.5 a ver que tal ya que es la única que no he probado, pero en general todo bastante mal.

    Espero que lleguen al lanzamiento del Rift con todas estas papeletas solucionadas, porque a día de hoy me da la impresión de que Valve se va a tomar esas cosas más en serio.
    Win 8.1 - Core i7 930 2.80 GHz. 18Gb DDR3. Nvidia GeForce GTX 460.
    0 0
  • Neoskynet

    13 Ago 2014 16:39

    Mensajes: 1947

    Ubicación: Barcelona

    Neoskynet » 26 JUN 2015  22:13
    Acabo de probar (más bien estrenar) Elite Dangerous con la 0.5.0.1 y se veía superborroso, como si tuviera desactivada la baja persistencia. He puesto el DK2 como única pantalla (con las teclas Windows+P) y ha funcionado bien y todo se ve muy suave.

    Como acaba de salir la 0.6.0.1-beta la voy a probar a ver que tal va. Bajaré a la versión de drivers de Nvidia 350.12, que dice que es la que tenemos que utilizar para que todo vaya bien.

    Saludos.
    * Nuestro cerebro es un sistema de simulación que virtualiza todo lo que capta del exterior.
    0 0

Usuarios navegando por este foro: